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An Overview of An Overview of SolidWorksSolidWorks and Its and Its 
Associated Analysis ProgramsAssociated Analysis Programs

prepared by Prof. D. Xue 
University of Calgary

•• SolidWorksSolidWorks -- a solid modeling CAD tool. 
•• COSMOSWorksCOSMOSWorks -- a design analysis system fully 

integrated with SolidWorks, providing one screen solution 
for stress, frequency, buckling, thermal, and optimization 
analyses.

•• COSMOSXpressCOSMOSXpress -- aan easy-to-use stress analysis tool
•• COSMOSMotionCOSMOSMotion –– aa mechanical system simulation 

software. 

SolidWorksSolidWorks
1. Introduction
(1) What is SolidWorks?
A Design Automation 
Software Package Used to 
Produce 
• Parts
• Assemblies
• Drawings

(From Planchard and Planchard 2003)
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(2) Starting Up
Window: Start->Programs->SolidWorks 2005-> SolidWorks 2005

(3) References
• Online Help
Menu: Help->SolidWorks Help Topics

• Online Tutorial
Menu: Help->Online Tutorial

• Book:
D. C. Planchard and M. P. Planchard, Engineering Design with 
SolidWorks 2005, SDC Publications, 2005

D. C. Planchard and M. P. Planchard, Engineering Design with 
SolidWorks 2004, SDC Publications, 2004

D. C. Planchard and M. P. Planchard, Engineering Design with 
SolidWorks 2003, SDC Publications, 2003
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(4) SolidWorks Model Types

Type Function Data File

Part 3-D Object *.SLDPRT

Assembly Many Parts *.SLDASM

Drawing Multi-views *.SLDDRW

e.g.,
Base.sldprt
Base-Rod.sldasm
Base.slddrw

2. Part Modeling
(1) Setting Up Unit
Menu: Tools->Options
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(2) 3-D Object Creation Procedure
By Creating Features

Top Plane + Block – Hole

Each Feature: 
• 2-D Sketching
• 3-D Formation

(3) 2-D Sketching
Parametric Modeling
(a) Procedure
• Sketch the geometry
• Dimension the geometry 
• Modify the dimension values
e.g., 

1.
51

0.
35

0.42 1.43 1 1

1
1
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(b) 2-D Object Creation Methods
Menu: Tools->Sketch Entities

Line Centerpoint Arc Tangent Arc 3 Point Arc

Circle Spline Rectangle Point

(c) Additional 2-D Object Creation Methods
Menu: Tools->Sketch Tools

Mirror Fillet Chamfer

Offset Entities Trim Extend
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(d) Dimensioning
Menu: Tools->Dimensions

Linear Radial Angular

(e) Relations
Menu: Tools->Relations

Horizontal Vertical Collinear Perpendicular

Parallel Tangent Midpoint Coincident

Concentric Symmetric Equal Coradial
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(4) Features

Extruded Boss/Base Revolved Boss/Base

Extruded Cut Revolved Cut

Sweep Boss/Base
Lofted Boss/Base

Fillet Chamfer
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Linear Pattern Circular Pattern

Mirror
Dome

(5) Reference Geometry

Plane Axes
X

Y

Z

Coordinate System

e.g.,

A reference plane for creating a sketch of 
revolved cut feature
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(6) Viewing
Menu: View->Display

Wireframe Hidden Lines 
Visible

Hidden Lines 
Removed

Shaded With 
Edges

Menu: View->Modify

Zoom to Fit Pan Rotate

3. Assembly Modeling
(1) Loading the Components
Menu: Insert->Component->Existing Part/Assembly
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(2) Defining Mates
Menu: Insert->Mate

(3) Exploded View
Menu: Insert->Exploded View

(From Planchard and Planchard 2003)
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4. Drawing Modeling
2-D Drawing of a Part or an Assembly

(From Planchard and Planchard 2003)

(1) Drawing Template and Drawing Format

Orientation
• Landscape
• Portrait
Size
• A
• B
• A4
• A3
... ...

Menu: File->New->Draw

(From Planchard and Planchard 2003)
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(2) Creating Views
Menu: Insert->Drawing View
• Standard 3 View

(From Planchard and Planchard 2003)

• Model View

(From Planchard and Planchard 2003)

Model View

Orientation
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• Derived Drawing Views

Projected View Auxiliary View Detail View

Crop View Broken-Out 
Section Section View

(3) Dimensions
Menu: Tools->Options
Select Styles of Font, Leader, Precision, Tolerance, Arrow, etc.

Two Ways to Create Dimensions
(i) Display All Dimensions and Then Modify These Dimensions
Menu: Insert->Model Items
Select Checkboxes
• Dimension
• Import items into all views

(ii) Create Required Dimensions Manually
Menu: Tools->Dimensions
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(4) Annotations
Menu: Insert->Annotations

3 x 25 ABC

Note

1

Balloon Datum Feature Symbol

Surface Finish Symbol Geometric Tolerance Center Mark

(5) Bill of Materials
Menu: Insert->Tables->Bill of Materials

(From Planchard and Planchard 2003)
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COSMOSWorksCOSMOSWorks
COSMOSWorks is a design analysis system fully integrated with 
SolidWorks. COSMOSWorks provides one screen solution for 
stress, frequency, buckling, thermal, and optimization analyses.

COSMOSWorks Manager Tree
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Structure Analysis Steps
1. Create a study defining its analysis type and options.

2. If needed, define parameters of your study. 

3. Define material properties.

4. Specify restraints. 

5. Specify the loads.

6. Mesh the model.

7. Link the parameters to the appropriate study inputs.

8. If desired, define up to 100 design scenarios.

9. Run the study or selected design scenarios.

10. View and list the results.

Design Studies
(1) Analysis Types
• Static: Linear static analysis
• Frequency: Frequency analysis
• Buckling: Linearized buckling analysis
• Thermal: Thermal analysis
• Optimization: Optimization analysis

(2) Mesh Types 
• Solid 
• Shell mesh using mid-surfaces 
• Shell mesh using surfaces 
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Isotropic and Orthotropic Materials
(1) Isotropic Materials
A material is isotropic if its mechanical and thermal properties are 
the same in all directions. 
(2) Orthotropic Materials
A material is orthotropic if its mechanical or thermal properties 
are unique and independent in three mutually perpendicular 
directions. 

Material Properties
• Elastic Modulus 
• Shear Modulus
• Poisson’s Ratio
• Coefficient of Thermal Expansion
• Thermal Conductivity
• Density
• Specific Heat
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Summary of Restraint Types

Spherical FacesOn Spherical Face

Cylindrical FacesOn Cylindrical Face

Planner FacesOn Flat Face

Vertices , Edges , and FacesUse Reference Plane or Axis

Vertices , Edges , and FacesImmovable (fixes translations only)

Vertices , Edges , and Faces Fixed (fixes translations and rotations)

Load EntitiesRestraint Type

Structural Loads 
• Pressure (uniform or nonuniform distribution)
• Force (uniform or nonuniform distribution)
• Gravity
• Centrifugal Load
• Remote Loads (direct load transfer , rigid connection , 

remote displacement )
• Bearing Loads
• Connectors (Rigid, Spring, Pin, Elastic Support) 
• Temperature (prescribed temperatures, uniform temperature 

change, or a temperature profile from a thermal study)
• Motion Loads from COSMOSMotion (available from 

COSMOSWorks, Import Motion Loads)
• Shrink Fitting (applied as a contact condition )
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Solid Mesh
• Draft Quality Mesh:
The automatic mesher generates linear tetrahedral solid 
elements.
• High Quality Mesh: 
The automatic mesher generates parabolic tetrahedral solid 
elements.

Shell Mesh
• Draft Quality Mesh:
The automatic mesher generates linear triangular shell 
elements. 
• High Quality Mesh: 
The automatic mesher generates parabolic triangular shell 
elements. 
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Plotting Results

• Stress results
• Principal stresses
• Contact Pressure
• Displacement results
• Strain results
• Deformation results
• Thermal results
• Fatigue results

Listing Results
•Listing Stress
•Listing Contact/Friction Forces
•Listing Pin/Bolt Forces
•Listing Displacement
•Listing Reaction Forces
•Listing Interface Forces
•Listing Strain
•Listing Modes
•Listing Mass Participation Ratios
•Listing Thermal Results
•Listing Results on Selected Entities of the Model
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References

• Online Tutorial:  
Menu: Help->COSMOSWorks Online Tutorial

• Online Help:
Select Windows Menu:
Programs -> COSMOS 2005 Applications -> COSMOSWorks
Documentation -> English -> Online Help

COSMOSXpressCOSMOSXpress
An Easy-to-use Stress Analysis Tool
An Example:
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Stress Analysis
Stress or static analysis calculates the displacements, strains, and 
stresses in a part based on material, restraints, and loads. 

Why Analyze?
After building your design in SolidWorks, you may need to answer 
questions like:
• Will the part break?
• How will it deform?
• Can I use less material without affecting performance?

Finite Element Method (FEM)
• FEM replaces a complex problem with many simple problems. 
• It divides the model into many small pieces of simple shapes 

called elements.
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Assumptions of Linear Static Analysis

(1) Linearity Assumption
The induced response is directly proportional to the applied loads. 
For example, if you double the magnitude of loads, the model's 
response (displacements, strains, and stresses) will double. 

(2) Elasticity Assumption
The part returns to its original shape if the loads are removed (no 
permanent deformation).

(3) Static Assumption
Loads are applied slowly and gradually until they reach their full 
magnitudes. 

Analysis Steps
(1) Define material of the part
(2) Apply restraints
(3) Apply loads
(4) Analyze the part
(5) View the results



24

Assigning Material

(1) To assign material from the material library

(2) To define material properties:
• EX (Elastic Modulus).
• NUXY (Poisson's ratio). If you do not define NUXY, 

COSMOSXpress assumes a value of 0.
• SIGYLD (Yield Strength). Used to calculate factor of safety .

Applying Restraints
• Each restraint can contain multiple faces. 
• The restrained faces are constrained in all directions. 
• You must at least restrain one face of the part to avoid analysis 

failure due to rigid body motion.
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Applying Loads
(1) Forces
You can apply multiple forces to a single 

face or to multiple faces.
• Normal to each selected face 
• Normal to a reference plane 

(2) Pressure
You can apply multiple pressures to a single face or to multiple

faces. COSMOSXpress applies pressure loads normal to each 
face.

Analyzing the Part
• Yes (recommended) to accept the default mesh settings (default 

element size and tolerance values)
• No, I want to change the settings to change the default mesh 

settings.
• Element Size
• Element Tolerance
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Viewing the Results
• The Stress Distribution in the Model
• The Deformed Shape of the Model

What More Can I Do With COSMOSWorks?

• Analysis of assemblies: 
In addition to analyzing parts, you can analyze assemblies. You 
can assign a different material for each component.

• Stress analysis with contact conditions: 
Friction and large displacement options are supported by 
contact analysis.

• Shell modeling of sheet metal and thin parts: 
COSMOSWorks uses small number of shell elements instead of 
a large number of tetrahedral elements to mesh thin parts . 
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Analysis Types
In addition to extensive stress analysis options in every step of the 
design analysis process, COSMOSWorks offers the following 
additional types of analyses:

• Frequency (modal) analysis
• Buckling analysis
• Thermal analysis
• Optimization analysis
• Other types of analyses

Frequency Analysis
• A body disturbed from its rest position tends to vibrate at certain 

frequencies called natural, or resonant frequencies. For each 
natural frequency, the body takes a certain shape called mode 
shape. Frequency analysis calculates the natural frequencies and
the associated mode shapes.

• Frequency analysis can help you avoid resonance by calculating 
the resonant frequencies. It also provides information to solve 
dynamic response problems.
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Buckling Analysis
Slender models subject to compressive axial 
loads tend to undergo sudden large lateral 
deformation at certain load levels. This 
phenomenon is called buckling. In some 
cases, buckling occurs before the material 
fails due to high stresses.
COSMOSWorks helps you avoid buckling 
failure by calculating minimum loads that 
cause buckling.

Thermal Analysis
(1) Conduction:
Conduction is the transfer of heat by means of molecular agitation 
within a material without any motion of the material as a whole.
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(2) Convection:
Convection is the transfer of heat by means of moving fluids. 

(3) Radiation: 
Radiation is the transfer of heat by means of electromagnetic 
waves. 
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Optimization Analysis

• Objective: 
State your objective. For example, minimum material.

• Design Variables or Geometry Constraints: 
Select the dimensions that can change and set their ranges. For 
example, the diameter of a hole can vary from 0.5" to 1.0" while
the extrusion of a sketch can vary from 2.0" to 3.0".

• Behavior Constraints: 
Set the conditions that the optimum design must satisfy. For 
example, stresses, displacements, temperatures should not exceed
certain values and the natural frequency should be in a specified 
range.

Other Types of Analysis
• Nonlinear static and dynamic stress analysis
• Dynamic response analysis
• Fluid flow analysis (COSMOSFloWorks)
• Motion simulation (COSMOSMotion)
• Electromagnetic analysis (COSMOSEMS)
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COSMOSMotionCOSMOSMotion
COSMOSMotion is design software for mechanical system 
simulation. 

IntelliMotion Browser
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Motion Analysis Steps

(1) Review your product concept

(2) Add constraints to define assembly movement

(3) Apply motion to the constraints in your mechanism

(4) Add applied loads (optional, COSMOSMotion only)

(5) Run a simulation of the mechanism

(6) Review the simulation results

Parts in Motion Analysis
• Moving Parts: Parts with Motion
• Ground Parts: Parts without Motion
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Types of Constraints

• Joints

• Joint Primitives

• Motion Drivers

• Contact

Joints and Degree-Of-Freedom (DOF)
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(2) Translational Joint

Types of Joints

(1) Revolute Joint

(3) Cylindrical Joint (4) Spherical Join

(5) Universal Joint

(6) Screw Joint

(7) Planar Joint (8) Fixed Joint

Types of Joints
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Joint Primitives and DOF

Types of Joint Primitives



36

Motion Drivers

You add motion drivers to joints to define the movement of the 
joint over time. 

Motion Types:

• Displacement: D(t)

• Velocity: V(t)

• Acceleration: A(t)

Contact Constraints
• Point-curve:
Restricts a point on one rigid body to lie on a curve on a second 
rigid body
• Curve-curve:
Constrains one curve to remain in contact with a second curve
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Types of Forces

• Applied Forces:
− Action-only force
− Action-only moment
− Action/reaction force
− Action/reaction moment
− Impact force

−Flexible Connectors:
− Translational Springs
− Torsion Springs
− Translational Dampers
− Torsion Dampers
− Bushings 

• Gravity

Simulation Settings

• Number of Frames
• Duration or Time Increment
• Animate during Simulation
• Use Mass Properties Stored with Parts

Solver Parameters:
Integrator Type, Maximum Iterations, Initial Time Step, 
Maximum Time Step, Minimum Time Step, Accuracy, Jacobian
Pattern, Adaptivity
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Reviewing Results
• Play animations
• Check for interference as the parts move
• Display result symbols on screen
• Plot numerical data
• Use part force results in COSMOSWorks
• Export your animations to AVI movies and VRML format
• Export force results to Excel, text file, or other FEA 

applications

References

• Online Tutorial:  
Select Windows Menu:
Programs -> COSMOS 2005 Applications -> COSMOSMotion
Documentation -> English -> Online Tutorials

• Online Help:
Select Windows Menu:
Programs -> COSMOS 2005 Applications -> COSMOSWorks
Documentation -> English -> Online Help


