Parametric Technology Corporation

Pro/ENGINEER® Wildfire® 4.0
Design Animation Concepts Guide
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>1-1</td>
</tr>
<tr>
<td>Introducing Design Animation</td>
<td>1-2</td>
</tr>
<tr>
<td>Accessing Design Animation</td>
<td>1-2</td>
</tr>
<tr>
<td>Learning Design Animation Basics</td>
<td>2-1</td>
</tr>
<tr>
<td>Terminology</td>
<td>2-2</td>
</tr>
<tr>
<td>About the Design Animation Interface</td>
<td>2-3</td>
</tr>
<tr>
<td>Timeline</td>
<td>2-5</td>
</tr>
<tr>
<td>Limitations</td>
<td>2-6</td>
</tr>
<tr>
<td>Creating an Animation</td>
<td>3-1</td>
</tr>
<tr>
<td>Overview</td>
<td>3-2</td>
</tr>
<tr>
<td>Using Bodies</td>
<td>3-3</td>
</tr>
<tr>
<td>Taking Snapshots</td>
<td>3-4</td>
</tr>
<tr>
<td>Defining a Key Frame Sequence</td>
<td>3-5</td>
</tr>
<tr>
<td>Working with Servo Motors</td>
<td>3-6</td>
</tr>
<tr>
<td>Body Locking</td>
<td>3-6</td>
</tr>
<tr>
<td>Working with an Event</td>
<td>3-6</td>
</tr>
<tr>
<td>Connection Status</td>
<td>3-7</td>
</tr>
<tr>
<td>Working with the Animation Appearance</td>
<td>3-7</td>
</tr>
<tr>
<td>Design Animation Tips</td>
<td>3-8</td>
</tr>
</tbody>
</table>

Index
Design Animation is a tool for creating animation sequences using Pro/ENGINEER parts, assemblies, and mechanisms previously created in Mechanism Design. Read the following topics for an introduction to Design Animation and information on how to get started:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introducing Design Animation</td>
<td>1-2</td>
</tr>
<tr>
<td>Accessing Design Animation</td>
<td>1-2</td>
</tr>
</tbody>
</table>
Introducing Design Animation

The Design Animation module enables you to animate mechanisms or assemblies previously created in Mechanism Design or Pro/ENGINEER. It differs from Mechanism Design in that you can create animation sequences by linking a series of snapshots, with no need to create motion axes or servo motors.

Design Animation is meant for both casual and expert Pro/ENGINEER users. Any designer or engineer can use Design Animation to:

- generate high-quality animations for sales and marketing presentations, management meetings, or design reviews
- animate assembly, disassembly, and maintenance sequences
- create complex, composite animations

The components of an animation can be controlled through the Design Animation timeline, which appears below the graphics window. Use the timeline to display, edit, move, and synchronize the components of the animation.

When creating an animation, you begin by creating key frame sequences which describe the position and orientation of parts and assemblies at specific times during the animation. The system interpolates between the frames in the sequence to produce a smooth animation. You can include a sequence of key frames in an animation multiple times.

You can also control animation sequences by identifying key events during the animation to trigger subanimations (copies of animations inserted into the timeline) or other effects such as view orientation, transparency, and magnification. These view changes enable you to emphasize the most important aspects of your animation by focusing attention on the parts of the model that change during the animation.

You can define servo motors and specify a time in the animation when they will be active.

Another feature that adds to the versatility of Design Animation is multiple-body locking. You designate a lead body and one or more follower bodies, and specify a time during the animation when the body lock is active. During this time, the follower bodies will follow the lead body in the same relative position in which they were when the lock took effect, as if they were glued together.

You can define an animation for a subassembly, and use it when the subassembly is included with an animation of the parent assembly. This makes it easy to define animations for small subsets of a large assembly, and bring them together for a combined presentation.

Accessing Design Animation

Access Design Animation from the Pro/ENGINEER Applications menu. You can:

- work within the Pro/ENGINEER user interface
• call up existing Pro/ENGINEER models
• use Pro/ENGINEER visualization, file manipulation, graphics, and printing tools

Servo motors, snapshots, bodies, and connection definitions created in Mechanism Design are inherited by Design Animation.

**Note:** If you have not used Mechanism Design to build your assembly, you cannot use the connection status or motion axis-based servo motor functionalities in Design Animation.
Learning Design Animation Basics

Before using Design Animation, read the following topics to become familiar with its interface and terminology:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terminology</td>
<td>2-2</td>
</tr>
<tr>
<td>About the Design Animation Interface</td>
<td>2-3</td>
</tr>
</tbody>
</table>
Terminology

The following list describes commonly used Design Animation terms.

<table>
<thead>
<tr>
<th>Item</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>animation time domain</td>
<td>the time period, number of intervals, or time step for the current animation</td>
</tr>
<tr>
<td>body</td>
<td>a combination of parts that move together as one unit</td>
</tr>
<tr>
<td>connection</td>
<td>a set of constraints that ties two bodies together and restricts the relative motion of the bodies in some or all directions</td>
</tr>
<tr>
<td>connection status</td>
<td>defines the state (Enable, Disable, Locked, Unlocked) of a connection at a given time during an animation</td>
</tr>
<tr>
<td>display at time</td>
<td>defines the display of each component in an assembly at a given time (Blank, Wireframe, Hidden Line, No Hidden, or Shaded)</td>
</tr>
<tr>
<td>event</td>
<td>a named point in time. An event acts as a reference for other animation components or events</td>
</tr>
<tr>
<td>key frame sequence</td>
<td>a set of snapshots that establish the location of specific bodies at specific times</td>
</tr>
<tr>
<td>key frame sequence instance</td>
<td>a copy of a key frame sequence included on the timeline</td>
</tr>
<tr>
<td>multi-body locking</td>
<td>a temporary rigid attachment of follower bodies to a lead body for a specific period of time</td>
</tr>
<tr>
<td>servo motor</td>
<td>a component that defines the relative motion of two bodies along a motion axis</td>
</tr>
<tr>
<td>servo motor instance</td>
<td>a copy of a servo motor included on the timeline for a specific period of time</td>
</tr>
<tr>
<td>snapshot</td>
<td>a picture of the model that shows the bodies in a specific position and orientation</td>
</tr>
<tr>
<td>subanimation</td>
<td>an animation included as a component in the current animation. A subanimation appears on the timeline as a line. Click the circle at the beginning or end of the timeline to display subanimation components.</td>
</tr>
<tr>
<td>system-defined events</td>
<td>default events defined by the system for each animation component, including start and end times.</td>
</tr>
</tbody>
</table>
### transparency at time
defines the degree of transparency for a selected assembly component at a given time

### view at time
a saved view that defines the orientation and magnification at which a model is viewed at a given time

### About the Design Animation Interface
The following table lists Design Animation command buttons, their function, and the menus on which they appear.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Location</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Create a new animation</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Animation</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Control icon display on your model</td>
<td>Animation toolbar</td>
<td>The <strong>Display Entities</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Define bodies in the model</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Bodies</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create, edit, remove or include a key frame sequence</td>
<td>Animation menu</td>
<td>The <strong>Key Frame Sequences</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create a key frame sequence</td>
<td>Animation toolbar</td>
<td>The <strong>Key Frame Sequence</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create body-body locking</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Lock Bodies</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create a servo motor</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Servo Motor Definition</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create a new view at a specific time</td>
<td>Animation toolbar and menu</td>
<td>The <strong>View @ Time</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Create a new transparency at a specific time</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Transparency @ Time</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Define component display at a specific time</td>
<td>Animation toolbar and menu</td>
<td>The <strong>Display @ Time</strong> dialog box opens.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Edit the selected entity on the timeline</td>
<td>Animation toolbar and Edit menu</td>
<td>The dialog box depends on the selected entity.</td>
</tr>
<tr>
<td>Icon</td>
<td>Function</td>
<td>Location</td>
<td>Result</td>
</tr>
<tr>
<td>------</td>
<td>----------</td>
<td>----------</td>
<td>--------</td>
</tr>
<tr>
<td><img src="image" alt="Undo" /></td>
<td>Undo Animation toolbar</td>
<td>Animation toolbar</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Redo" /></td>
<td>Redo Animation toolbar</td>
<td>Animation toolbar</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Remove" /></td>
<td>Remove Animation toolbar</td>
<td>Animation toolbar</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Generate Animation" /></td>
<td>Generate the animation Animation toolbar and menu</td>
<td>Generates a new animation from defined events.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Play Animation" /></td>
<td>Play back the animation Animation toolbar and menu</td>
<td>Plays back the current animation.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Export Animation" /></td>
<td>Export the animation to a frame file Animation toolbar</td>
<td>Exports and saves the current animation as a .fra file.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Change Connection Status" /></td>
<td>Change the connection status Animation menu</td>
<td>The <strong>Connection Status</strong> dialog box opens.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Include Subanimation" /></td>
<td>Include a subanimation Animation menu</td>
<td>The <strong>Include in Animation</strong> dialog box opens.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Create Event" /></td>
<td>Create an event Animation menu</td>
<td>The <strong>Event Definition</strong> dialog box opens.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>Zoom in on the time scale View menu</td>
<td>The time scale decreases to the selected size. Click and drag a rectangle around the part of the time scale you want to see.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>Zoom out on the time scale View menu</td>
<td>The time scale increases incrementally until it reaches the original setting.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Refit Time Scale" /></td>
<td>Zoom to refit the time scale View menu</td>
<td>The time scale returns to the original setting.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Change Time Domain" /></td>
<td>Change the animation time domain Tools menu</td>
<td>The <strong>Animation Time Domain</strong> dialog box opens.</td>
<td></td>
</tr>
</tbody>
</table>
### Timeline

The Design Animation timeline is a graphic interface that appears below the Pro/ENGINEER window when you start Design Animation. The timeline displays the items that make up your animation on a line drawing associated to a time scale. The components that make up the animation—including key frame sequence instances, servo motor instances, and connection status—are represented by triangles, diamonds, or circles connected by a line.

Use the menu commands or Design Animation toolbar buttons to add components to the timeline or edit existing components. You can also right-click a component in an existing animation timeline and choose **Edit**, **Copy**, or **Remove** from the shortcut menu. Press and hold the middle mouse button to move the component vertically.

The timeline is not only a convenient way to represent an animation; you can also use it to change the animation’s time parameters. You can change the time at which a specific event occurs by dragging the event’s symbol to a different location on the timeline. For example, you can change the time when an animation or key frame sequence begins or ends by left-clicking on the desired sequence and dragging the line connecting the separate components to a new location with respect to the time scale. You can also position the key frame sequence for convenient viewing.

The following is an example of a Design Animation timeline:
As the animation progresses, the components become active and move associated bodies to their desired positions. Multiple components may be active at any given time. An animation can also contain servo motor start and end times, animation view orientations and transparency states, and show or hide component information.

**Limitations**

Following are the limitations associated with Design Animation:

- All components (bodies, motion axes, servo motors) created in Mechanism Design can be used in Design Animation.
- You can use snapshots and servo motors created in Design Animation in Mechanism Design.
- The view orientation is not saved when you export an animation as a frame file (extension `.fra`).
- Constraints and locked bodies (to ground) are saved with a snapshot. However, they are not enforced during a key frame sequence animation. You may need to define body locks and connections within Design Animation to achieve the desired animation.
- View interpolation settings must be set for the entire animation. These settings are not honored in subanimations.
- Animation components can be deleted when opening a simplified representation or when supressing components. If you then save the animation and open the master representation, information may be lost. To make certain that all data is retained in the master rep animation, do not save the simplified rep.
Creating an Animation

Use the Design Animation timeline and toolbar to create an animation for your assembly. The following topics introduce the components of an animation and their functions.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>3-2</td>
</tr>
<tr>
<td>Using Bodies</td>
<td>3-3</td>
</tr>
<tr>
<td>Taking Snapshots</td>
<td>3-4</td>
</tr>
<tr>
<td>Defining a Key Frame Sequence</td>
<td>3-5</td>
</tr>
<tr>
<td>Working with Servo Motors</td>
<td>3-6</td>
</tr>
<tr>
<td>Body Locking</td>
<td>3-6</td>
</tr>
<tr>
<td>Working with an Event</td>
<td>3-6</td>
</tr>
<tr>
<td>Connection Status</td>
<td>3-7</td>
</tr>
<tr>
<td>Working with the Animation Appearance</td>
<td>3-7</td>
</tr>
<tr>
<td>Design Animation Tips</td>
<td>3-8</td>
</tr>
</tbody>
</table>
Overview

You can create an animation to do many different things. Depending on your objective, you may use different steps to create your animation. Following are the typical steps you might take to create an animation:

1. Open an assembly in Pro/ENGINEER and click **Applications > Animation** to start Design Animation.

2. Click **Animation > Animation** or on the toolbar to create a new animation. Click **Rename** and enter a name for your animation.

3. Click **Animation > Body Definition** or on the toolbar to check your body definitions:
   - When working with a Pro/ENGINEER assembly, select **One Part per Body** and then edit the body to put the parts into the appropriate moving groups. Since **One Part per Body** empties the ground body of parts, make sure to edit the ground body and reassign ground parts to it.
   - When working with a Mechanism Design assembly, make sure that the bodies are properly defined.

4. Now define the animation components that create movement:
   - Click on the toolbar or **Animation > Key Frame Sequence** to create key frame sequences to specify general movement. Click to move bodies to specific positions, and then take snapshots. Design Animation interpolates between these key frames to produce a smooth animation.
   - Click on the toolbar or **Animation > Servo Motor** to define servo motors and create specific movement between bodies connected by motion axes or between geometric entities.

5. Add the servo motors and key frame sequences to the timeline. Any components on the timeline form the basis of your animation. Edit the timeline length and increments, the length of the servo motor or key frame sequence, and the relative timing of all components in the timeline.
   Right-click and use the shortcut menu or click to edit a selected component.

6. If body locking, events, or connection status are not on the timeline, you can add them now:
   - Click on the toolbar or **Animation > Lock Bodies** to fix a group of bodies relative to each other for a specified part of the animation.
   - Change the connection status to help assemble or disassemble your model. For key frame sequences, click to change the connection.
Creating an Animation

status in the Drag dialog box while dragging bodies to position them, and then take snapshots.

- To edit servo motors, right-click a selected servo motor, and then choose Edit Definition from the shortcut menu, or click on the toolbar or Animation > Connection Status.

- Click Animation > Event to define a specific sequence of events.

7. After everything has been defined, click on the toolbar or Animation > Start to run the animation.

8. If the animation does not run as expected:

- Make sure your mechanism is not overconstrained. For example, check that a servo motor and a key frame sequence do not require conflicting positions.

- Try increasing the number of time steps by clicking Tools > Time Domain.

9. Click on the toolbar or Animation > Playback to run the animation again and change the speed or direction, or to check for interference and other results.

10. Click on the toolbar or Animation > View @ Time to define views along the animation to display model orientations and magnifications.

11. Click Tools > Animation Interpolation to choose an interpolation method for your views.

12. Click on the toolbar or Animation > Display @ Time to specify component displays along the animation for your assembly components.

13. Click on the toolbar or Animation > Playback to rerun the animation and view results.

14. Click File > Save to export the animation as a .fra file and save it with the model’s .asm file, or click CAPTURE on the Playbacks dialog box to save your results as an .mpeg, .jpeg, .tiff, .bmp or .pba file.

See the following sections for more information about bodies, snapshots, key frame sequences, servo motors, events, connection status, and body locking.

Using Bodies

A body is made up of one or more parts that do not move relative to each other. By default, bodies in Design Animation are created following the Mechanism Design body rules—parts with a constraint between them are placed in a single body. You can define a group of parts as a body in Design
Animation, or you can add components to a body that was defined in Mechanism Design.

Body definition is important because you can define movement and create body locking only between distinct bodies. Keep the following points in mind when creating body definitions:

- Body definitions created in Design Animation will not transfer to Mechanism Design.
- Depending on the constraints used to create your assembly, you may want to redefine the model using One Part per Body or Add.
- If a body definition has been edited and saved in a subassembly, you cannot edit the body in a higher level assembly. You must edit the body in the subassembly and then save it.
- If a subassembly body configuration has not been saved, the default body definition is created automatically. The default definition can then be edited.

When you add parts to a body, they are deleted from any other bodies that previously contained them. If you delete a body, all of its parts are moved into the ground body.

Editing body definitions may cause connections, servo motors, and other animation components to become invalid. Invalid components are permanently deleted from the animation timeline.

**Note:** Any change you make to a body definition in Design Animation will only be valid while you are in Design Animation. You cannot transfer the body definition to Mechanism Design.

**Taking Snapshots**

Click on the toolbar to open the Drag dialog box and move bodies into place for a snapshot. You can drag a point, an edge, or a surface of a body that is not defined as ground. You can select a free-form dragging movement or a movement along a coordinate system axis.

In a snapshot, the selected entity is positioned as close as possible to the pointer location. The coordinates of the drag point shown in the Drag dialog box are updated as you move the model. You can use the coordinates to place your component more precisely, or to recall a previous position. Use the Constraints tab to apply or remove constraints to the movement of your model.

Assembly bodies can be fixed relative to a single lead body. During a dragging operation, the locked bodies behave as if glued together, with no movement between them. The bodies do not need to be touching or adjacent to be locked together.

You can also lock or disable a motion axis. During a dragging operation, the locked or disabled motion axis will not move or will be ignored, respectively. These settings are saved with the snapshot and are active when the snapshot is edited.
After the model is properly placed, click 📷 to create the snapshot.

**Note:** When you use the **Drag** dialog box to create snapshots, you must manually include each snapshot in the desired key frame sequence.

### Defining a Key Frame Sequence

A key frame sequence is made up of a series of snapshots of your assembly in a succession of positions and at specific times. The system interpolates between the snapshots to create a smooth animation.

Click **Animation > Key Frame Sequences** to open the **Key Frame Sequences** dialog box. Use it to select a reference body, take snapshots, and arrange them into a key frame sequence. When you create a new key frame sequence, it is automatically included on the timeline.

You create a key frame by moving the model into a desired orientation and taking a snapshot. After a group of snapshots is prepared and saved, you place them in the desired order in a key frame sequence. The snapshots can be reordered and used in other key frame sequences.

While creating or editing a key frame sequence, you can preview existing snapshots, change the order of the snapshots, make new snapshots, and add snapshots to the key frame sequence. When you include the key frame sequence as an instance in an animation, it appears in the timeline window.

Each key frame is represented by a triangle, and a line connects the triangles. You can drag a triangle on the timeline to a different time and the associated key frame will update automatically.

When creating the sequence, you control the importance of each body's location by specifying whether its status is **Required**, **Desired**, or **Unspecified**. Any body that has its status set to **Unspecified** is not controlled by the sequence. You also select a reference body, which can be ground, for the entire sequence. All bodies whose status is **Required** or **Desired** in that sequence are placed in the appropriate position, as defined by the snapshot, relative to the reference body at each time in the sequence. If the reference body moves, all of the controlled bodies in the sequence move with it.

When you run the animation, if the bodies, especially at key frames, do not move to the correct position, try changing the status of these bodies to **Required**.

**Note:** Use the **Required** setting cautiously, as it may over-constrain your assembly.

To reverse a key frame sequence, click 📷 on the toolbar to open the **Key Frame Sequence** dialog box, and then click the **Sequence** tab and select **Reverse**. This command can be useful, for example, if you want to show how a mechanism is assembled. Create a snapshot as you remove each part of your assembly and save the snapshots in a key frame sequence. Now reverse the sequence to produce an animation that shows how an assembly is put together.
**Working with Servo Motors**

Servo motors impose a specific type of motion on bodies in a mechanism without taking the forces required to cause the motion into account. You can place servo motors on motion axes or between geometric entities.

When you define a servo motor, you must specify how you want the motion to change with respect to time—either by position, velocity, or acceleration—and whether the motion axis is translational or rotational. You can use several system-defined servo motor profiles, including ramp, parabolic, and polynomial. You can also define your own servo motor, using a table or a mathematical expression. A servo motor that is defined, edited, or copied in Design Animation or Mechanism Design is valid in either applications.

To create a new servo motor, click **Animation > Servo Motor**, and then click **New** on the **Servo Motors** dialog box, or click **Servo Motor** on the toolbar.

After you have defined a servo motor, you can include a single or multiple instances of it in the animation. Each servo motor instance can be applied at a different time. Servo motor function is activated relative to the instance start time.

**Body Locking**

You can use the multi-body locking functionality to lock bodies to a lead body. Design Animation determines the relative position and orientation of the follower bodies with regard to the lead body at the time the body locking becomes active in the animation and keeps them in this same orientation while the lead body moves according to the animation’s definition. When body locking ends in the animation, the bodies are allowed to move independently again.

**Working with an Event**

Use events to maintain an associative relationship between animation elements. For example, suppose that you set a timeline component to start when another one ends and the animation end time changes. All elements that are defined to start after the end time are automatically updated.

Events for the beginning and end of any animation component included in the current animation are created automatically. In most cases, you can use a system-defined event and will not have to create one yourself.

When you click **Animation > Event**, the **Event Definition** dialog box opens. Use this dialog box to:

- Name the event.
- Select a reference event. Use the down-arrow to display the list of available reference events.
- Set the time after the selected reference event that you want the event to start.
When you create a new event, a symbol with the name of the event appears on the timeline. When you define an animation element start time, a relationship is set between the element and the event, and a dotted line appears between the two.

In the following figure, the animation includes:

- Two key frame sequences: Kfs3.2 starts at time 0 and Kfs1.4 starts at time 2.
- Two connection status events: a motion axis is disabled at time 1 (shown by a hollow circle) and enabled at time 2 (shown by a solid circle).

All four of these components are defined with respect to Event2, which is defined as beginning at the start of the animation.

Now you insert the third key frame sequence, Kfs2.6, in front of the sequence of events and define the animation start time as Kfs2.6 Start. You also change the Event2 start time to 2 seconds after Start. The other events that are linked to Event2 automatically shift ahead in time. Their relationship to each other does not change.

### Connection Status

Click **Animation > Connection Status** or click on the toolbar to make a servo motor connection inactive or disabled during a specific period of time during the animation. Use this command, for example, to illustrate disassembly of your model, or to focus on the movement of one connection at the expense of others.

### Working with the Animation Appearance

After you are satisfied with the movement of your assembly during the animation, you can adjust the animation's appearance to emphasize specific parts.

- Use the **View @ Time** command in conjunction with the **Animation Interpolation** command to ensure a smooth transition from one orientation of the model to another. For example, you can begin the
animation with a top view of the assembly and then zoom in on a moving part.

- Use the **Display @ Time** command to control the display of assembly components during an animation. You can define a display representation during which some of the components are invisible or are displayed in different modes (Wireframe or Hidden Line, for example). Although you can create several **Display @ Time** events for your animation, only one can be active at a time. One **Display @ Time** event moves to another with no interpolation.

- Use the **Trans @ Time** command to control the transparency of your assembly components at specific times during an animation. You can make a component partially transparent so you can see through the component's surfaces, or you can make the component completely invisible. You can a component completely opaque, then smoothly make its surfaces transparent, so that the components hidden beneath it gradually become visible. This is useful when you want to focus your animation on the components hidden inside other components.

**Design Animation Tips**

The following tips can make using Design Animation easier:

- By default, a key frame sequence controls the locations of all of the bodies during an animation. If you want the bodies to move more freely—for example, if a servo motor needs to move them—make sure that the body definition is **Unspecified** rather than **Desired** when defining a key frame sequence.

- When creating constraints during drag, multiple planar constraints can easily lock up an assembly if they close a loop. As it is very difficult to keep plane normals aligned, try to avoid closing loops or using other constraint types.

- When adding a constraint to a long chain of connected bodies, try to add the constraints to bodies that are close to each other.

- Key frame sequences have a lot of freedom to move around the parts. When parts move unexpectedly, try tying things down using body locking and constraints.

If you are using an assembly created in Mechanism Design, you should use **Lock Bodies** to regroup parts into groups if you are creating the animation after an assembly sequence.
A
Animation
  definition of time domain, 2-2
  steps to create, 3-2
  using body locking, 3-6
Animation time domain, definition, 2-2

B
Bodies
  definition, 2-2
  using in animation, 3-3
Body locking, 3-6

C
Connection status
  definition, 2-2
  description, 3-7
Connection, definition, 2-2

D
Design Animation
  introduction, 1-2
  limitations, 2-6
  overview, 3-2
  taking snapshots, 3-4
  terminology, 2-2
  timeline, 2-5
  timeline example, 2-5
  toolbar window, 2-3
  using a key frame sequence, 3-5
  using an event, 3-6
  using bodies, 3-3
  using servo motors, 3-6

E
Event
  definition, 2-2
  example, 3-6
  system-defined, 2-2
  using in animation, 3-6

K
Key frame sequence
  defining, 3-5
  definition, 2-2
Key frame sequence instance, definition, 2-2

M
Multi-body locking, definition, 2-2

S
Servo motor instance, definition, 2-2
Servo motors
  definition, 2-2
  using in animation, 3-6
Snapshots
  definition, 2-2
  taking, 3-4
Steps to create an animation, 3-2
Subanimation, definition, 2-2
System-defined events, definition, 2-2

T
Time domain, definition, 2-2
Timeline window
  example, 2-5
  example of event, 3-6
Transparency at time, definition, 2-3

V
View at time, definition, 2-3