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Pro/MFG Volume Milling Tutorial 
 

OBJECTIVES: 
 The Manufacturing module in Pro/E is used to generate machine code to produce 

parts. This tutorial will focus on Pro/MFG Volume Milling.  A volume milling NC 

sequence removes the material inside a Milling Volume slice by slice.  All slices are 

parallel to the retract plane.  Some typical applications for volume milling are: 

• Facing down the workpiece 

• General material removal on the side of the workpiece 

• Rough milling of a vertical slot or cut, or a blind slit with islands 

• Pocketing finishing by using the ROUGH_OPTION parameter value 

PROF_ONLY 

PROCEDURES: 
Index: 

A. Product the part model       p. 1 

B. Create workpiece        p. 6 

C. Perform the machining operation setup     p. 8 

D. Define machine operations (create a mill volume) or    p. 10 

E. Define machine operations (create a mill window -- the simplest way to define 

geometry for a Volume milling NC sequence)    p. 14 

F. Create cutter location file and NC code     p. 17 

 
Start: 

A. Produce the part model. The part consists of two features, together forming a 

block (4” x 8” x 1.5”) with raised letters “CAD” as shown in Figure 1.12. 

1. Start the Pro/E program. Windows menu items, Start → All Programs → PTC 

→ Pro ENGINEER→ Click on the icon  Pro ENGINEER. 
2. Set working directory. File → Set Working Directory, select working 

directory. 
3. Create the part name. Pro/E main menu, File → New, select Part in the New 

window, enter part name: CAD. 
4. Start of the part.  The part contains some features already.  The main graphics 

area shows 3 datum planes and a coordinate system as shown in Figure 1.1. 
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Figure 1.1 Start of the Part 
 

5. Create a 4” x 8” x 1.5” rectangular block as shown in Figure 1.8. 
• Choose INSERT → EXTRUDE from the menu.  You should see a new 

toolbar called dashboard appear as shown in Figure 1.2. 
 

Figure 1.2 The Dashboard 
 

• Click on the placement on the extrude dashboard (Figure 1.3) and select 
define.  The sketch dialog window appears as shown in Figure 1.4. 

 

   
 
Figure 1.3 The Extrude Dashboard  Figure 1.4 Sketch dialog 
 
Choose the datum place FRONT by clicking on it in the graphics window.  
Accept the default on the sketch dialog window and just click on the 
Sketch button. References sub-window pop up as shown in Figure 1.5 and 
click close to start sketch. 
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Figure 1.5 References dialog  Figure 1.6 The Sketcher toolbar 
 

• Choose Create Rectangle icon on Sketcher Toolbar (Figure 1.6) to sketch 
a rectangle for extrusion in plane FRONT by clicking on the bottom-right 
and top-left corners of the rectangle in the drawing windows.  Click 
middle mouse to finish drawing the rectangle. 

• Modify the dimensions to 4 x 8 by double clicking on the dimensions on 
the rectangle. To end sketching choose Accept icon on Sketcher Toolbar 
(Figure 1.6) and click OK in the Section dialog. 

• Extrude the rectangle to form the solid block. Enter depth value as 1.5 into 
the depth field of the extrude dashboard (Figure 1.3) and click the Accept 
tick to finish (Figure 1.7). 

• View the rectangular block as shown in Figure 1.8. View → Orientation 
→ Standard Orientation. 

 
 

 
 
Figure 1.7 Dashboard controls 
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Figure 1.8 Block 

 
 

6. Create 2” x 6” x 0.5” letters “CAD” on top of the block as shown in Figure 
1.12. 
• INSERT → EXTRUDE from the menu.  The dashboard appears as shown 

in Figure 1.2. 
• Click on the placement on the extrude dashboard (Figure 1.2) and select 

define.  The sketch dialog window appears as shown in Figure 1.9. Choose 
top surface of the block as sketch plane and accept the default on the 
sketch dialog window and click on the Sketch button.  

• Produce letters. Sketch → Text from the menu and pick two points on the 
sketch plan to determine the height of the text and enter letters CAM as 
shown in the figure 1.10. Modify the size of the text to 2 x 6 and locate the 
text to the center of the block as shown in figure 1.11. 

 
 

   
 Figure 1.9 Sketch dialog  Figure 1.10 The Text dialog 
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Figure 1.11 Letter CAD 

 
 
 

• Extrude the text to 0.5” out of the block. 
• View the created part (Figure 1.12). View → Orientation → Standard 

Orientation. 
• Save the part. File → Save and Exit or Close to continue. 

 

 
Figure 1.12 Part model 
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B. Create the workpiece.  The workpiece represents the raw stock of material from 
which the part will be machined.  Pro/E refers to this procedure as an assembly 
operation.  

 
1. Start the Pro/E program. Windows menu items, Start → Programs → PTC → 

Pro ENGINEER→ Click on the icon  Pro ENGINEER. 
2. Set working directory. File → Set Working Directory, select working 

directory. 
3. Create the part name. Pro/E main menu, File → New, select Manufacturing in 

Type window and NC Assembly in Sub-type window, enter name: mfgCAD 
as shown in Figure 1.13 

        
 
Figure 1.13 Creating a new file   Figure 1.14   Figure 1.15 
 

4. Load the part. From MANUFACTURE menu, select Mfg Model → Assemble 
→Ref. Model. Select cad.prt in the open window. The component Placement 
window pops up. Select  to place the part at default location as shown in 
Figure 1.16 and click OK.  Click OK to close Create Reference Model as 
shown in Figure 1.17. 

 

       
 

  Figure 1.16     Figure 1.17 
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5. Create a workpiece 4”x 8”x2.25”. From MANUFACTURE menu, select Mfg 
Model → Create → workpiece. Enter a name for the workpiece: wpcad. 
Select Solid  Protrusion  Extrude  Solid  Done. Select 
NC_ASM_FRONT as sketch plane and NC_ASM_RIGHT as reference plane 
in Figure 1.18. Create a rectangle 4”x8” surrounding the CAD part as shown 
in Figure 1.20 with references as shown in figure 1.19 and extrude it to 2.25” 
as shown in Figure 1.21. 

 

    
Figure 1.18    Figure 1.9 

 

 
Figure 1.20 
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    Figure 1.21 Reference Model and Workpiece 
 

C. Perform the machining operation setup. The setup consists of defining the type 
of machine to use. It also requires defining a coordinate system if one does not 
already exist and a retraction plane for the cutting tool.  The coordinate system 
must match the mill orientation and the part zero. 

 
1. Insert  Model Datum  Coordinate system. Coordinate system window pop 

up automatically as shown in Figure 1.22. 
2. Pick 3 references planes as shown in Figure 1.23 (Click two side and top 

planes while holding down Ctrl key) to place the coordinate system. 
3. Orient X and Y axes (Figure 1.24) along the top edges as shown in Figure 

1.23 by clicking the Flip button as shown in Figure 1.24. 
 

    
    Figure 1.22    Figure 1.23   Figure 1.24 
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4. MFG Setup → Operation.  Operation Setup window pops up automatically as 
shown in Figure 1.25. 

5. Define NC machine. Click NC machine icon  in Figure 1.25, Machine 
Tool Setup windows pop up as shown in Figure 1.26.  Enter the parameters as 
shown below 

Machine name: HAAS 
Machine type: Mill 
Number of Axis: 3 
CNC control: VF-2 
 

   
Figure 1.25     Figure 1.26 
 

6. Define Machine Zero. Click Reference Machine Zero icon  
in Figure 1.25.  Select the coordinate system ACS0 just created. 

7. Define retract plane. Click Retract Surface icon  in Figure 
1.25. Retract Setup window pops up (Figure 1.28). Enter 0.5, click OK to 
close the window.  The retract plane is shown in Figure 1.29. 

8. Complete Operation setup. Click OK to close operation setup as Figure 1.30. 
MFG Setup  Done  Return. 

 

  
Figure 1.28   Figure 1.29 Defining the Retract Surface 
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Figure 1.30 Completed Operation Setup 

 
D. Define the machining operations (create mill volume). The setup consists of 

defining the type of tool to use and machining parameters (tools size, cutting 
speed, etc.), and specify the volume of material to be removed.  

 
1. Machining → NC Sequence → Volume → 3 Axis → Done. 
2. SEQ SETUP window pops up. Ensure that name, tool, parameters and 

volume are checked and then choose DONE. (Figure 1.31).  
 

 
    Figure 1.31  
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3. Enter NC sequence name: Volcut 
4. Tools setup table pops up.  Enter the tool values cutter diameter 0.25” and 

length 4” as shown in Figure 1.32 and APPLY OK.  
 

 
Figure 1.32 

5. Edit Parameters window pops up.  Input or change the values as shown in 
Figure 1.33.  File  save as to file called “milprmVol”  click OK to 
exit. 

 

 
  Figure 1.33 
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6. Select Mill Volume windows pop up as shown in figure 1.34. Since Mill 
Volume has not been created, there is no volume to select.  Click 

 Tool to create the volume. 
 

   
Figure 1.34    Figure 1.35 
 

7. Create and Define a Volume. To specify the volume of material to be 
removed.  

• Click on Sketch Tool  to sketch.  Select NC_ASM_FRONT as 
sketch plane and NC_ASM_RIGHT as Reference plane Right as 
shown in Figure 1.35. 

 
• Sketch a rectangle window 4” x 8” exactly on the top of workpiece as 

shown in figure 1.36. Click on  to exit sketch. 
 

 
Figure 1.36 



 13

• Click on Extrude tool  to extrude a rectangle to 2.25” (similar 
to the workpiece).  

 
• We have sketched our entire workpiece. But we need to leave the 

material that represents our part. At this point Pro/E provides a Trim 
function that will “trim” the part from mill volume.  Select Trim and 
select the part we wish to be “trimmed” out of the mill volume as 
shown in Figure1.37.  We have defined the volume to be removed (the 
workpiece minus the part). 

 

 
Figure 1.37 

 
8. View tool path.  Machining  NC Sequence  Play path  NC Check. 

The cutting path is shown in Figure 1.38.  
 

 
Figure 1.38 
 

9. After this completes choose DONE SEQ.  If you don’t do this, you are 
likely to lose the definition of this NC sequence. 
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E. Define the machining operations (create mill windows). The setup consists of 
defining the type of tool to use and machining parameters (tools size, cutting 
speed, etc.), and specify the volume of material to be removed.  

 
1. Machining → NC Sequence → New Sequence  Volume → 3 Axis → 

Done. 
2. SEQ SETUP window pops up.  Ensure that name, tool, parameters, and 

window are checked and then choose DONE. (Figure 1.39). 
 

 
Figure 1.39 

 
3. Enter NC sequence name: Wincut 
4. Tool setup table pops up. Click ok to use tool 1 as previous tool (see 

Figure 1.32). 
5. Edit parameters window pop up.  File  open  select milprmVol  

open  Ok (see figure 1.33). 
6. Select Wind window pop up as shown in figure 1.40. Since a windows had 

not been created, there is no windows to select. Click on Mill Windows 

Tool to create the window as shown in figure 1.41. 
 

       
Figure 1.40    Figure 1.41 
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7. Create and define a Mill Window.  To specify the volume of material to be 

removed. We defined a “mill windows” on the top surfaceof our 
workpiece that include the entire workpiece.  Think of the workpiece was 
being transparent and the surface as being solid.  If you look down through 
the mill windows, you will see all the volume of the material in the 
workpiece located around the surface. 

• Click on the Sketch window type  to define the window plane and 
sketch the window.  Select top surface as sketch plane and click on the 
define an Internal sketch to sketch as shown in Figure 1.42. 

 

 
Figure 1.42 

 
• Sketch Window pops up. Select NC_ASM_RIGHT as reference 

RIGHT as shown in Figure 1.43. Click on Sketch. 
 

 
Figure 1.43 

 
• References Window pop up. Select two planes as shown in Figure 

1.44. 

 
Figure 1.44 
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• Sketch a rectangle window 4” x 8” exactly on the top of the workpiece 

as shown in Figure 1.45.  Click on . Click on Options and choose 

ON Window Contour as shown in Figure 1.46 and Click . 
 

  
Figure 1.45    Figure 1.46 

 
8. View tool path. Machining  NC Sequence  Play path  NC Check.  

The cutting path is shown in Figure 1.47. 
 

 
Figure 1.47 

 
9. After this completes Choose DONE SEQ.  If you don’t do this, you are 

likely to lose the definition of this NC sequence.  
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F. Create cutter location file and NC code.  
 

1. Machining → CL Data → Output → Select Feature → NC Sequence → 
volcut. PATH → FILE → Done. Enter name: volcut in the Save a Copy 
window. Pro/E will save the file as volcut.ncl.1.  

2. The cutter location file can be converted to G-code file through Pro/E post 
processor for HAAS VF-2 CNC milling machine.  

3. Post Process on the CL DATA menu.  Select the file volcut.ncl from the 
Open Dialog box and select Open to close the window.  In the PP Options 
menu make sure the Verbose and Trace option are selected. 

4. Post processing is the act of converting the toolpaths from a standard language 
file, called a cutter location file (**.ncl), to the language of our specific CMC 
machine controller, i.e.c G-codes. 

5. Select Done on the PP OPTIONS menu and a list of post processors appears. 
6. Choose the UNCX01.p15 Option. 
7. A file the the extension “.tap”, i.e., volcut.tap is created, which contain the G-

code. 
8. Close the information window and Select DONE/RETURN from CL DATA 

menu. 
9. Open the volcut.tap file to view using program WORDPAD.  
 
The volcut.tap file is shown below: 
% 
N0005(FADAL VMC 6030 - VH65) 
N0010G90G40G80 
N0015T1M6 
N0020S3000M3 
N0025G0X6.0282Y2.025 
N0030G43Z.5H1 
N0035G1Z-.25F30. 
N0040X1.9782 
N0045Y1.975 
…………… 
N4815X3.989Y1.8059 
N4820X4.3944 
N4825X4.1917Y2.4269 
N4830X3.989Y1.8059 
N4835X4.1268 
N4840Z.5 
N4845M5 
N4850M2 
% 

 
 


